Support Announcements
(non-US) DSL-2875AL / (non-US) DSL-2877AL :: Device Credential Disclosure and Authentication Bypass :: FW v1.00.01 & v1.00.05

D-Link is aware that a 3rd party researcher has recently reported two vulnerabilities in the DSL-2875AL and DSL-2877AL modems pertaining to remote and local disclosures.   After thorough investigation, D-Link has confirmed that the latest firmware released in 2016 (version 1.00.08) resolved the remote and Local password disclosure issue reported for the DSL-2875AL.  D-Link has also confirmed that the second reported issue regarding remote and local information disclosure does not affect users of either modem.


D-Link takes the issues of network security and user privacy very seriously.  We have a dedicated task force and product management team on call to address evolving security issues and implement appropriate security measures.  Please check the D-Link website regularly to make sure your devices are updated with the latest firmware.
 

DSL-2875AL :: Firmware v1.00.08AU 20161011 ::

http://files.dlink.com.au/products/DSL-2875AL/REV_A/Firmware/Firmware_v1.00.08AU_20161011/DSL2875ALA1_FW1.00.08AU_20161011.bin


DSL-2877AL ::  Firmware 1.00.20AU 20180327 :: 

http://files.dlink.com.au/products/DSL-2877AL/REV_A/Firmware/Firmware_1.00.20AU_20180327/DSL2877ALA1_FW1.00.20AU_20180327.bin